problème interrupteur électronique

+3
tuxstang
pleinair37
crawl85
7 participants

Aller en bas

problème interrupteur électronique Empty problème interrupteur électronique

Message  crawl85 Sam 1 Jan - 18:55

Bonjour,

J'ai un problème avec 2 interrupteurs électroniques qui ne fonctionnent pas. Ils sont neufs, et les récepteurs sont aussi neufs.

Quelqu'un peut il me dire ce que je suis sensé avoir comme tension au niveau du signal sur la voie 3 du récepteur (elle est programmée pour faire du on/off) quand je l'active ? Actuellement je passe de 0 à 0,5V... Est ce une tension normale et suffisante pour piloter l'interrupteur ?

Merci de vos retours

a++
crawl85
crawl85

Ville ou Région : vendée
Age : 40
Date d'inscription : 12/04/2021
Messages : 552

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  pleinair37 Sam 1 Jan - 19:15

Au pifomètre de précision, je dirais du 6v... Après ça dépend comment est réglé ton ESC, mais en général ça sort du 6v.

_________________
François.

ICI l'évolution de mon TRX4 Defender, ICI mon Axial Capra, ICI mon E-Revo 2.0, ICI mon TRX4 Bronco, ICI ma remorque porte-bateau, et ICI ma chaine Youtube...

Et que Dieu vous garde, moi j'ai pas l'temps...
pleinair37
pleinair37
Modérateur

Ville ou Région : Montlouis sur Loire (37)
Age : 52
Date d'inscription : 23/06/2017
Messages : 6422

https://www.rc-decouverte.com/t530-mon-traxxas-trx4-a-moi

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  tuxstang Sam 1 Jan - 20:12

Si tu veux mesurer la tension au fil signal de la 3ème voie, ce n'est pas une tension fixe mais un signal pulsé sur 5v ... donc suivant la réactivité de ton multimètre et la position de la voie, tu vas mesurer une tension entre un peu plus de 0 et un peu moins de 5v

tuxstang

Ville ou Région : idf
Age : 51
Date d'inscription : 27/01/2019
Messages : 313

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  crawl85 Sam 1 Jan - 21:15

Merci pour vos réponses. Pour être certain qu'on parle de la même chose, voici la photo du récepteur :


problème interrupteur électronique Flysky-2-4g-3ch-r-cepteur-pour-fs-gt3-fs



Le signal est sur le pin de gauche, en suite il y a le V+ que je mesure tout le temps à 5V et le pin de droite à 0V. Le signal S dans mon cas ne doit pas être pulsé si c'est juste du tout ou rien ... ou j'ai loupé un truc ? en tous cas j'ai soit 0V soit 0,5V fixe .

En réalité j'ai ce même résultat sur 2 récepteurs neufs, l'un en 3 voies comme ici et l'autre en 6. Les interrupteurs électroniques sont neufs aussi, je pige pas pourquoi ça fonctionne pas, ou alors problème de programmation de la chanel 3 ?
crawl85
crawl85

Ville ou Région : vendée
Age : 40
Date d'inscription : 12/04/2021
Messages : 552

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  tuxstang Sam 1 Jan - 21:52

Tu as forcément un signal pulsé, c'est comme ça que sont pilotés les servos.
Le problème c'est qu'un multimètre n'est pas l'outil idéal pour diagnostiquer un signal pulsé, surtout si c'est un multimètre basique comme on a tous ... il va sortir la moyenne de la tension qu'il mesure, cette moyenne va changer en fonction de la forme de la pulsation ou de sa fréquence (selon qu'on soit en mode analogique ou numérique) et de la fréquence d'échantillonnage du multimètre.

Le moyen de plus simple de tester une voie d'un récepteur, c'est encore d'y brancher un servo ... ça te permet de t'assurer que la voie fonctionne et de visualiser l'action de la commande sur la radio. Mais si tout est neuf, récepteur comme interrupteurs, sauf a pas avoir de bol, il y a de fortes chances que ce soit lié à la programmation de la radio.

tuxstang

Ville ou Région : idf
Age : 51
Date d'inscription : 27/01/2019
Messages : 313

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  cefawano Sam 1 Jan - 23:10

Je pense que l’interrupteur doit avoir soit 0, soit 100% pour fonctionner.
Peut être que ta télécommande n’est pas configurée comme ça ?
Si Flashy passe par là, il pourra certainement t’expliquer tout ça
cefawano
cefawano

Ville ou Région : Cordemais (44)
Age : 45
Date d'inscription : 13/01/2021
Messages : 354

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  louloux44 Sam 1 Jan - 23:29

Euh. Si on faisait plus simple....

Peux tu nous dire ce que tu as branché exactement sur cette 3ème voie ?

Et nous montrer le bouton ou interrupteur sur la télécommande qui pilote cette voie ?

Car (par exemple) si tu branches un accessoire qui se pilote par bouton on/off sur une voie on/off/on ou de type potentiomètre ou inversement, ça risque de mal fonctionner et tu pourrais penser que le problème vient du récepteur ou de la tension.


_________________




Aidez Rc Découverte pour plus de tutoriels, moins de publicités et pas mal d'autres services : le formulaire et interface de don

Pour plus d'informations : les explications, discussions, questions/réponses des membres de Rc Découverte autour des donations
louloux44
louloux44
Admin

Ville ou Région : Nantes Sud 44 / Ile Maurice
Age : 46
Date d'inscription : 19/02/2015
Messages : 15625

https://www.dailymotion.com/rc-decouverte

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  Jérôme85 Dim 2 Jan - 7:30

Commence par nous dire se que tu a collé radio (même si j’ai un doute au niveau du récepteur )!
Elle est reprogrammé ?
Jérôme85
Jérôme85

Ville ou Région : La Boissière de Montaigu (85)
Age : 32
Date d'inscription : 11/10/2020
Messages : 2812

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  pleinair37 Dim 2 Jan - 12:02

Moi ce que je comprends c'est qu'il utilise sa 3ème voie pour allumer un truc (genre rampe de leds) et qu'il a un interrupteur entre le vario et la rampe pour l'allumer quand il veut...

_________________
François.

ICI l'évolution de mon TRX4 Defender, ICI mon Axial Capra, ICI mon E-Revo 2.0, ICI mon TRX4 Bronco, ICI ma remorque porte-bateau, et ICI ma chaine Youtube...

Et que Dieu vous garde, moi j'ai pas l'temps...
pleinair37
pleinair37
Modérateur

Ville ou Région : Montlouis sur Loire (37)
Age : 52
Date d'inscription : 23/06/2017
Messages : 6422

https://www.rc-decouverte.com/t530-mon-traxxas-trx4-a-moi

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  crawl85 Dim 2 Jan - 12:05

Salut les copains !

Merci pour votre aide. J'ai enfin trouvé la solution, je vous ferai une vidéo pour vous montrer ça sera plus simple.

En gros mon interrupteur électronique ne fonctionne que sur une certaine plage de réglage de la voie 3. Il faut rentrer dans les paramètres de la radio pour mettre une valeur comprise entre 19% et 89% ... en dessous de 19 et au dessus de 89 les lumières ne fonctionnent pas. Pour moi, comme c'était juste du on/off, il fallait balancer la sauce à 100% pour ON et à 0% pour off ... mais visiblement non ...

je vous fais une vidéo plus tard, radio en main.

a++
crawl85
crawl85

Ville ou Région : vendée
Age : 40
Date d'inscription : 12/04/2021
Messages : 552

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  patcha Dim 2 Jan - 12:45

ton problème vient certainement de la plage étendu du signal PWM de la radio. et comme ton inter doit fonctionner entre 1ms et 2 ms, tu dois réduire la plage ce qui expliquerait tes 19% et 89%.
tu as un lien vers ton inter ?


Pour info, pour mesurer la valeur du signal, il te faut un oscillo.
Imagine, ton signal dure 20ms( donc 50Hz ) avec une plage haute qui dure entre 1ms pour le début de course et 2ms pour la fin de course.( valeurs pour des servo standard 180° ) Ton multimètre est forcement a la ramasse.

patcha
patcha

Ville ou Région : saché (37)
Age : 61
Date d'inscription : 11/04/2018
Messages : 759

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  crawl85 Dim 2 Jan - 20:57

@patcha, voici le lien, mais peu de détails techniques...    : https://s.click.aliexpress.com/e/_9Ikgta

Je comprends bien pour la mesure au multimètre, à ces fréquences c'est mort c'est clair.

Voici la vidéo explicative, je trouve ce fonctionnement très vicieux quand même  Question





Merci à tous pour vos regards sur ce problème.


Dernière édition par crawl85 le Dim 2 Jan - 22:28, édité 1 fois
crawl85
crawl85

Ville ou Région : vendée
Age : 40
Date d'inscription : 12/04/2021
Messages : 552

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  louloux44 Dim 2 Jan - 21:34

Ta vidéo est en cours de traitement sans doute.

Ok tu as mis un inter électronique.
J'ai compris que la voie est de type bouton On/OFF.

Tu connectes quoi sur cette inter électronique ?




_________________




Aidez Rc Découverte pour plus de tutoriels, moins de publicités et pas mal d'autres services : le formulaire et interface de don

Pour plus d'informations : les explications, discussions, questions/réponses des membres de Rc Découverte autour des donations
louloux44
louloux44
Admin

Ville ou Région : Nantes Sud 44 / Ile Maurice
Age : 46
Date d'inscription : 19/02/2015
Messages : 15625

https://www.dailymotion.com/rc-decouverte

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  tuxstang Dim 2 Jan - 22:22

Dans le lien sur le produit, ils disent :
Please note:For this switch to work correctly you will need to set the related channel travel to + - 100%.
Donc ça signifie qu'il est prévue pour fonctionner sur une voie en inversion configurée -100/+100 ... pas une voie on-off configurée 0/+100 (ou 19/89).

tuxstang

Ville ou Région : idf
Age : 51
Date d'inscription : 27/01/2019
Messages : 313

Revenir en haut Aller en bas

problème interrupteur électronique Empty Re: problème interrupteur électronique

Message  crawl85 Dim 2 Jan - 22:33

louloux44 a écrit:Ta vidéo est en cours de traitement sans doute.

ça doit être bon, j'avais loupé une étape...


tuxstang a écrit:il est prévue pour fonctionner sur une voie en inversion configurée -100/+100 ... pas une voie on-off configurée 0/+100 (ou 19/89).

Je ne comprends pas le fonctionnement +/- 100% du truc mais en tous cas ça fonctionne maintenant
crawl85
crawl85

Ville ou Région : vendée
Age : 40
Date d'inscription : 12/04/2021
Messages : 552

Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum